Microsoft Outlook-Delayed Inbound Messages

Incident Report for Rowan County NC

Resolved

The email delay has been cleared; this issue is resolved.
Posted Dec 01, 2025 - 20:33 EST

Investigating

Some users are experiencing a delay on inbound emails from external senders. We are currently investigating this issue.
Posted Dec 01, 2025 - 14:39 EST
This incident affected: Microsoft 365 Applications (OneDrive, SharePoint, and Email).