Microsoft Outlook-Delayed Inbound Messages

Incident Report for Rowan County NC

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 09:03 EST

Monitoring

Some users are experiencing a delay on inbound emails from external senders. We are currently investigating this issue.
Posted Dec 02, 2025 - 11:56 EST
This incident affected: Microsoft 365 Applications (OneDrive, SharePoint, and Email).