ID Badge Readers

Incident Report for Rowan County NC

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 08:24 EDT

Investigating

We are currently experiencing intermittent issues with badge readers causing a delay in the release of the door. Staff are still able to badge into all locations, but they may experience a slight delay on the release of the lock. We are working with the vendor to resolve this problem as soon as possible.
Posted Jul 09, 2025 - 17:00 EDT
This incident affected: ID Badge Readers/Door Security.