Adobe Sign Issues Logging In

Incident Report for Rowan County NC

Resolved

This issue has been resolved; users are now able to log into Adobe Sign.
Posted May 13, 2026 - 15:55 EDT

Investigating

We are currently aware of an issue affecting Adobe Sign where some users are experiencing difficulty logging in.
Our team is actively investigating the issue and working to resolve as quickly as possible.
Posted May 13, 2026 - 08:52 EDT
This incident affected: Adobe (Acrobat, Sign, Creative Cloud, etc).