Countywide Network Outage From Equipment Failure

Incident Report for Rowan County NC

Resolved

We have repaired the faulty equipment, and network connectivity has been restored. Users should be able to resume work without further interruption. We appreciate your patience.
Posted Sep 02, 2025 - 14:41 EDT

Identified

We are experiencing a countywide network outage stemming from equipment failure. We are working to replace that equipment now, and hope to have the issue resolved as quickly as possible.
Posted Sep 02, 2025 - 12:32 EDT
This incident affected: Network Services (Internet, Site Connectivity, etc.).