Countywide Application Issues
Incident Report for Rowan County NC
Postmortem

This was an upstream outage with Cloudflare affecting many sites across the internet. Service was restored after scheduled maintenance was completed by Cloudflare.

Posted Sep 17, 2024 - 19:45 EDT

Resolved
This incident has been resolved, and all applications appear to be operational.
Posted Sep 17, 2024 - 15:06 EDT
Investigating
We are currently investigating issues affecting multiple applications countywide. We will continue to monitor and update staff as more information is available.
Posted Sep 17, 2024 - 14:11 EDT
This incident affected: Munis-Applications.