CivicClerk Agenda Management Login Error

Incident Report for Rowan County NC

Resolved

The system appears to be back up and working properly. If you experience any residual issues, be sure to clear your browser history/cache or try an incognito window if using Google Chrome.
Posted May 04, 2026 - 08:37 EDT

Investigating

Users needing to submit or view items for the Board of Commissioners agenda through CivicClerk are receiving the following error message: An error occurred while processing your request. Please try again. If this error persists, please contact CivicPlus Support. Request ID: 00-a006a42967fc10b9a831bab43f54ef11-d5e687df271ac8b9-00. A support ticket with our vendor has been entered and we will share updates as they are available. Thank you for your patience.
Posted May 04, 2026 - 08:15 EDT
This incident affected: CivicClerk.